Vector Linux 5

Information Center


VLAPT/slapt-get package manager


  1. Introduction
  2. install VLAPT and Slapt-get
  3. Specify Source
  4. Specify Working Directory
  5. Update the package list
  6. Install tha packages
  7. Other menus
  8. Known problems
  9. More packages info
10. Slackware packages to exclude
11. Metapackages
12. Credits


1. Introduction

Vector Linux 5.x has introduced a new package management system based on slapt-get.
This feature allows you to easily download and install a package along with its dependencies.
To use this system, the general steps are:

  • Install "slapt-get" and "vlapt" packages if they are not already installed. VL SOHO 5.0 beta and newer have it already, so you need to do this on VL Dynamite 5.0rc2 and VL SOHO 5.0 alpha only.
  • Specify the source (VL FTP site and Slackware FTP site).
  • Specify local working directory.
  • Update local information.
  • Let's rock, install the packages of your choice.


2. Install VLAPT and Slapt-get (for older VL 5.x only).

If VLAPT is already installed in your system you can skip to step 3.

Use a browser (firefox), go to this address:

Download: libidn, and curl.

Then to this address:

Download: slapt-get, vasm2, vlapt.

Install those 5 packages as usual:


# install BASE
installpkg libidn-*.tgz
installpkg curl-*.tgz
installpkg slapt-get-*.tgz

# remove the old vecpkg, replace it with vlapt
removepkg vecpkg2
installpkg vlapt-VERSION-noarch-4vl5.tgz

# upgrade vasm
upgradepkg vasm-VERSION-noarch-4vl5.tgz


3. Specify SOURCE.

Let's go, launch the vlapt.
This program works on console as well as X-Window.
However, the recomended way is from console, because generally, X-Windows may cause problem on installation.

The vlapt is simply a dialog frontend for the slapt-get engine, so the menu represents the right order to use slapt-get. If you don't like vlapt, or want to troubleshoot problems, you can always use slapt-get manually.

Firstly, select the SOURCE menu.
Enable the nearest VL and Slackware mirror.
At this moment, VL 5.0 is based on slackware current after Slackware 10.0.
You may stick with slackware stable (10.1 maybe) after Patrick freezes it.
So, for example, you may choose:

Manual way: edit /etc/slapt-get/slapt-getrc.



This is where the slapt-get puts the downloaded packages and other information.
By default, it is on /home/ftp/pub/veclinux-5.0.
The reason is, you may want to publish that directory using a FTP server to become a mirror.

To specify another directory, use VLAPT's WORKDIR menu.

Manual way: edit /etc/slapt-get/slapt-getrc


5. UPDATE the package list.

This step gets the necessary information from the FTP sites.
So make sure your internet connection is working, then choose the UPDATE menu on the vlapt.

Manual way:


slapt-get --update


6. INSTALL the packages.

On VLAPT, choose the INSTALL menu. It will ask you the search pattern, and guide you through the install and download process.

Manual way:


slapt-get --search <pattern>
slapt-get -s --install <package>
slapt-get --install <package>

That's it. Enjoy your new package.


7. Other menus.

You may want to try these menu entries from VLAPT/slapt-get:

  • FILTER = edit /etc/slapt-get/slapt-getrc, set the EXCLUDE setting.
  • UPGRADE = slapt-get --upgrade
  • NODEP = slapt-get --no-dep --install <package>
  • MIRROR = slapt-get --download-only --install <package>
  • REMOVE = slapt-get --remove <package>

For more information: "man slapt-get" or go to this site:


8. Known problems.

Due to 'do not reinvent the wheel' and 'interoperability' spirit, VL uses many Slackware packages.
Unfortunatelly, Slackware does not support slapt-get (yet). Thus, Slackware packages have NO dependency info, and may cause problems.

  • Same packages.
    A certain package might be available from VL site as well as Slackware site. For example:


# list the available abiword packages
root:# slapt-get --search abiword
abiword 2.0.11-i586-4vl5 [inst=no]: AbiWord (Light Word Processor)
abiword 2.0.12-i486-1 [inst=no]: abiword (AbiWord Personal)

Notice that the valid Slackware package name is: NAME-VERSION-ARCHITECTURE-RELEASE.tgz

Official Slackware package uses simple number for the release, e.g:

Other packages (such as on the must add a tag after the release number.
So VL packages uses '4vl5', which means 'release 4, Vector Linux 5'. For example : abiword-2.0.11-i586-4vl5.tgz.

  • Newest package.
    Slapt-get always suggests the newest package with the following priority:
    - Version. So abiword-2.0.12-i486-1.tgz is newer than abiword-2.0.11-i586-4vl5.tgz.
    - If the version are the same, slapt-get compare the release.
    So abiword-2.0.12-i486-4vl5.tgz is newer than abiword-2.0.12-i486-1.tgz.

If you use:


root:# slapt-get --install abiword

The newest package will be picked up.
Alas, sometimes you will get the Slackware package instead of the VL package. To install a specific package, use:


# install a specific version
root:# slapt-get --install abiword-2.0.11-i586-4vl5

In general, you should use VL packages over the Slackware packages, even if it is older bacause:
- Maybe we have added customization / patches. e.g: VL's icewm stays on version 1.2.13 but believe me, it is good.
- Maybe the newer package has problem, e.g: VL downgrade to cdrtools-2.0.3-i586-4vl5 because the newer cdrtools-2.01-i486-1.tgz is broken.

  • Broken dependency
    There is nothing wrong if you want install the newest package from Slackware (at your own risk).
    However, the Slakware package does not have the dependency info needed by slapt-get.
    So, assuming that the newest abiword is from slackware, this will not install it´s dependencies !


slapt-get --install abiword

In this case, maybe you have to do it twice


# Get abiword from VL first, to install all dependencies
root:# slapt-get --install abiword-2.0.11-i586-4vl5

# upgrade the abiword
root:# slapt-get --install abiword

  • Lame mirror.
    Your nearest Slackware mirror is not fast enough so a required package is not there yet.


root:# slapt-get -s --install abiword-2.0.11-i586-4vl5
Reading Package Lists... Done
The following packages have unmet dependencies:
abiword: Depends: x11 >= 6.8.1-i486-3
Excluding abiword, use --ignore-dep to override
The following packages have been EXCLUDED:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Blimey ... this abiword requires the newest x11-6.8.1-i486-3 available from - (Temporary patches while Patrick is ill).
On the VL dynamite rc2, the installed x11 is:


root@engrob4:# slapt-get --installed | grep x11
x11-devel - 6.8.1-i486-1
x11 - 6.8.1-i486-1
x11-fonts-misc - 6.8.1-noarch-1
x11-fonts-100dpi - 6.8.1-noarch-1
x11-fonts-cyrillic - 6.8.1-noarch-1
x11-xnest - 6.8.1-i486-1
x11-fonts-scale - 6.8.1-noarch-1

Ah ... the version is still the same. Only the build release is different.
So we can use ignore-dep like this.


root:# slapt-get --ignore-dep -s --install abiword-2.0.11-i586-4vl5
Reading Package Lists... Done
The following packages have unmet dependencies:
abiword: Depends: x11 >= 6.8.1-i486-3
The following NEW packages will be installed:
aspell aspell-en fribidi gtk+2 libglade glib2 abiword
The following packages will be upgraded:
bash libxml2
2 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 15863K of archives.
After unpacking 48720K of additional disk space will be used.
aspell-0.60-i486-2 is to be installed
aspell-en-6.0_0-noarch-2 is to be installed
fribidi-0.10.4-i586-4vl5 is to be installed
gtk+2-2.4.13-i486-1 is to be installed
libglade-2.4.0-i486-1 is to be installed
glib2-2.4.7-i486-1 is to be installed
abiword-2.0.11-i586-4vl5 is to be installed
bash-3.0-i486-1 is to be upgraded to version 3.0-i486-2
libxml2-2.6.9-i486-1 is to be upgraded to version 2.6.15-i486-1

If you do not want to ignore it, you should change the SOURCE to an updated Slackware/VL mirror.


9. More package info

If you want more info for a specific package, try:


root:# slapt-get --show abiword-2.0.11-i586-4vl5
Package Name: abiword
Package Mirror:
Package Location: ./x11/gtk2/OFC
Package Version: 2.0.11-i586-4vl5
Package Size: 3685 K
Package Installed Size: 10930 K
Package Required: aspell >= 0.60-i486-2,aspeel-en,fribidi >= 0.10.4-i586-4vl5,gtk+2 >= 2.4.13-i486-1,libglade >= 2.0.1-i586-4vl5,bash >= 3.0-i486-2,libxml2 >= 2.6.15-i486-1,zlib >=,atk >= 1.6.1-i486-1,pango >= 1.6.0-i486-1,glib2 >= 2.4.7-i486-1,x11 >= 6.8.1-i486-2,libpng >= 1.2.7-i486-1,popt >= 1.7-i386-1,cxxlibs >= 5.0.6-i486-1,gcc-g++ >= 3.3.4-i486-1,expat >= 1.95.7-i486-1
Package Conflicts:
Package Suggests:
Package MD5 Sum: aeb7f5302b15e3db8fb3de5eebcf42f1
Package Description:
abiword: AbiWord (Light Word Processor)
abiword: AbiWord is cross platform word processor. It is
abiword: available on Linux, BSD, Windows, QNX, Mac, and more.
abiword: Abiword can handle style, image, and table. So it is
abiword: good enough to handle serious documents like report,
abiword: mail, or thesis. More over, it can import and export
abiword: MS Word document.
abiword: Website:
abiword: License: GNU GPL
abiword: Author: Thomas Fletcher <>
abiword: Author: Jeff Hostetler <>
abiword: Author: et.all.
Package Installed: no

Notice that VL packages usually have the REQUIRED field, and possibly the SUGGESTS and CONFLICTS field.
The Slackware packages do not have this information.


10. Slackware packages to exclude.

With slapt-get in place, people are tempted to track Slackware-current.
However, you MUST NOT upgrade these Slackware packages on a VL system (put these on the EXCLUDE list):

- sysvinit
This package is needed, but only for first time install.
If you upgrade/reinstall it, it overwrites VL init scripts, and will cause havoc !

- pkgtools
This is also needed, but VL has patched it with vlfix-pkgtools.
If you do, installing packages will leave garbages on /install.

- hotplug
VL has patched it with vlfix-hotplug.
If you reinstall this, something nasty could happen with your USB things !

- alsa-util
VL has patches for it on VASM.
If you reinstall it, sound volume will be muted/unmuted unexpectedly.

- kernel-ide, kernel-modules, kernel-header.
Unless you know what you are doing, do not reinstall the kernel.

The following are temporary, they should not be excluded if there is no problem in the newer version.

- cdrtools > 2.0.3
This package has fatal bugs, so VL uses downgraded it to 2.0.3.

- gdk-pixbuff > 0.17
VL SOHO has to use the older gdk-pixbuff that still supports GNOME 1.4, because it is used by gnucash.


11. Meta packages.

According to slapt-get´s FAQ


A meta package is a package that only contains it's dependencies.
There is nothing in the package to install,
it just provides a name and a dependency list.

Vector Linux provides such packages, for example:
- printing-pack : install cups, espgs, fomatix, etc ...
- gaming-pack : install all SDL games libraries.

To list the available meta packages, use VLAPT, don't forget to UPDATE, then select INSTALL. On the search dialog, enter "/meta". They will be presented to you.

In the long run, VL will provide flavour meta packages, e.g:
- vl-standard
- vl-soho

So if you are running VL standard, for example, to transform it into a VL SOHO, you would simply install the vl-soho meta package (it would be a HUGE download though !).


12. Credits

Copyright 2004 Vector Linux
Released under GNU Free Document License [ ]
Contributed By: Kocil, UKBill

VLAPT is a front end for slapt-get developed by Jason. [ ]